M.D.G. IT client area down for emergency maintenance
Incident Report for M.D.G. IT
Resolved
All services are now be operational, please contact support if you're experiencing any continuing issues.
Posted Jun 23, 2020 - 15:08 AEST
Identified
The M.D.G. IT client area is down during emergency hardware maintenance. No client services or networks are affected. ETA is < 60 minutes.
Posted Jun 23, 2020 - 13:59 AEST
This incident affected: Client Area, Billing system, and Ticket Support.