Inbound 1300 number calls failing
Incident Report for M.D.G. IT
Resolved
Our apologies for the inconvenience, phone support on 1300 023 123 is now operational.
Posted Mar 13, 2019 - 16:48 AEDT
Investigating
Calls to 1300 023 123 are currently failing due to 1300 number routing issues at our provider. We will update this issue as soon as an ETA is available.
Posted Mar 13, 2019 - 12:24 AEDT