The M.D.G. IT Client Area will be unavailable for approximately 10 minutes from 2:30 PM AEDST
Incident Report for M.D.G. IT
Resolved
Maintenance has been completed, and all services should be operating as normal
Posted 12 months ago. May 04, 2017 - 14:39 AEST
Investigating
The M.D.G. IT Client Area will be unavailable for approximately 10 minutes from 2:30 PM AEDST
Posted 12 months ago. May 04, 2017 - 14:26 AEST