The M.D.G. IT Client Area will be unavailable for approximately 25 minutes from 3:05 PM AEDST
Incident Report for M.D.G. IT
Resolved
Maintenance has been completed
Posted about 1 year ago. May 23, 2017 - 16:11 AEST
Identified
Please call support on 1300 023 123 for any critical support issues
Posted about 1 year ago. May 23, 2017 - 15:04 AEST