The M.D.G. IT Client Area will be unavailable for approximately 25 minutes from 1:40 PM AEDST
Incident Report for M.D.G. IT
Resolved
Maintenance has been completed
Posted over 1 year ago. Jul 06, 2017 - 14:02 AEST
Investigating
Please call support on 1300 023 123 for any critical support issues
Posted over 1 year ago. Jul 06, 2017 - 12:27 AEST