M.D.G. IT Client Area will be down for approximately 20 minutes for critical maintenance
Incident Report for M.D.G. IT
Resolved
Maintenance has been completed, and all services should be operating as normal
Posted almost 2 years ago. Dec 31, 2016 - 13:28 AEDT
Identified
The M.D.G. IT Client Area will be unavailable for approximately 20 minutes from 11:30 AM AEDST.
Posted almost 2 years ago. Dec 31, 2016 - 11:20 AEDT