12/7/2017 - Duplicate renewal emails from domain name registrar
Incident Report for M.D.G. IT
Resolved
This incident has been resolved.
Posted 6 months ago. Jul 12, 2017 - 10:44 AEST
Update
Due to upcoming changes at the upstream domain name registrar, clients may receive duplicate domain name renewal emails on Wednesday the 12th of July. These emails require no further action and can be safely ignored.
Posted 7 months ago. Jul 11, 2017 - 11:54 AEST
Identified
Due to upcoming changes at the upstream domain name registrar, clients may receive duplicate domain name renewal emails on Wednesday the 11th of July. These emails require no further action and can be safely ignored.
Posted 7 months ago. Jul 11, 2017 - 11:54 AEST