The M.D.G. IT Client Area will be unavailable for approximately 20 minutes from 12:30 PM AEDST
Incident Report for M.D.G. IT
Resolved
This incident has been resolved.
Posted about 2 months ago. Sep 20, 2018 - 14:02 AEST
Investigating
Please call support on 1300 023 123 for any critical support issues
Posted about 2 months ago. Sep 20, 2018 - 09:26 AEST